[BUGREPORTING] XeLL

Post all bugs you can find about XeLL/LibXenon/Linux, thx.
greator

Re: [BUGREPORTING] XeLL

Post by greator » Tue Dec 20, 2011 4:24 pm

XeLL-Rev: XeLL Reloaded 2f
Console Type: retail
Console Revision: Jasper 16mb
Hack-Version: JTAG reset glitch
Boot-Method: XeLL-Launch
Videocable: Composite and VGA
Error-Description: Stuck at executing xenon.elf.

I only managed to get it run one time, when running rawflash v3 to write retail image. When I go back and want to write ***, it doesn't work. I tried rawflash v4 and mupen emulator, also doesn't work. (Mupen does execute at first but stuck at loading the emulator, I reset the console and it doesn't execute anymore.)

Also tried booting from CD, still stuck at executing, so its not my USB stick problem.

User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

[BUGREPORTING] XeLL

Post by tuxuser » Tue Dec 20, 2011 4:42 pm

Use latest xell build, you can find it in  LibXenon -> XeLL -> XeLL Updates .. pretty much at the end of the thread
I have no idea what I am doing but atleast I am trying

DHeir

Build: XeLL_Reloaded-testing-git18122011_fix1

Post by DHeir » Tue Dec 20, 2011 5:40 pm

I have kboot.conf on root of USB stick. Apparently I made a type and it decided it wanted to continue to look for other avenues to boot from after timing out.
I pulled out the USB stick and made the correction to kboot.conf. Xell froze at  Trying uda:/initrd.gz. When I placed the usb stick back in I get red crash screen.

Ouput from that:

Code: Select all

Exception Vector! (0x600)

pir=0000000000000000 dar=00000000ec68fff3
sr0=0000000080029c18 sr1=0000000002003030 Ir=0000000080029c18

STACK DUMP:

0x80029c18 --> 0x80029c18 --> 0x8000fe20 --> 0x8001018c -->
0x80010b0c --> 0x80011440 --> 0x800117e8 --> 0x80011888 -->
0x80011948

I realize that maybe isn't a serious bug, however it's something worth reporting I thought.

greator

Re: [BUGREPORTING] XeLL

Post by greator » Tue Dec 20, 2011 5:43 pm

[quote="tuxuser"]
Use latest xell build, you can find it in  LibXenon -> XeLL -> XeLL Updates .. pretty much at the end of the thread
[/quote]

I already use the latest xell-reloaded-2stage-2011-09-23.

tried using debian liveCD. Fail, stuck at executing.
Last edited by greator on Tue Dec 20, 2011 8:54 pm, edited 1 time in total.

User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

Re: [BUGREPORTING] XeLL

Post by tuxuser » Tue Dec 20, 2011 11:12 pm

greator wrote: I already use the latest xell-reloaded-2stage-2011-09-23.
Try this one: Click me
I have kboot.conf on root of USB stick. Apparently I made a type and it decided it wanted to continue to look for other avenues to boot from after timing out.
I pulled out the USB stick and made the correction to kboot.conf. Xell froze at  Trying uda:/initrd.gz. When I placed the usb stick back in I get red crash screen.
Let me give you an example: You are installing Linux or Windows from a CD onto your computer. in the middle of the install-process you remove the installation-media! What will the setup program do? Right, it will report: Cant read file xyz. Please check your media.
As XeLL isnt really Plug'n'Play captable.. and also pretty low-level... it will error of course if you remove a media where its trying to load from atm. Dont expect us to fix it but thx for reporting it nontheless.
Last edited by tuxuser on Tue Dec 20, 2011 11:31 pm, edited 1 time in total.
I have no idea what I am doing but atleast I am trying

greator

Re: [BUGREPORTING] XeLL

Post by greator » Wed Dec 21, 2011 4:53 pm

[quote="tuxuser"]
[quote="greator"]
I already use the latest xell-reloaded-2stage-2011-09-23.
[/quote]

Try this one: Click me[/quote]

Oh yeah, I forgot to write on that one. I tried that but the xell didn't boot.

Maybe I didnt build it right.
Question: If I erase the nand, and then just write the xell file, will it work?

User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

[BUGREPORTING] XeLL

Post by tuxuser » Wed Dec 21, 2011 5:15 pm

nope, it wont work if you just write the xell binary. you need to build a new image with it.
I have no idea what I am doing but atleast I am trying

greator

Re: [BUGREPORTING] XeLL

Post by greator » Thu Dec 22, 2011 9:18 am

I wonder if the original nand is the cause of the xenon.elf not executing...

User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

[BUGREPORTING] XeLL

Post by tuxuser » Thu Dec 22, 2011 10:23 am

@greator: nope, that cant be the reason for not-launchin ELFs
I have no idea what I am doing but atleast I am trying

Ethereal

BUGREPORTiNG: Build: XeLL_Reloaded-testing-git01012012

Post by Ethereal » Sun Jan 15, 2012 12:14 am

XeLL-Rev: *XeLL_Reloaded-testing-git01012012*
Console Type: *Retail*
Console Revision: *Jasper 16MB*
Hack-Version: *RGH*
Boot-Method: *XeLL-Launch*
Videocable: *HDMI.*
Error-Description:
*Exception vector! (0x700)
pir=0000000000000000 dar=0000000080800000
sr0=00000000800164f8 sr1=1000000002883030 lr=00000000800160c0
(other rows follow from 00 to 07)
STACK DUMP: *0x800164f8 --> 0x800160c0 --> 0x800023b8 --> 0x8000a7f4*

Hope this helps.
Last edited by Ethereal on Sun Jan 15, 2012 12:25 am, edited 1 time in total.

Ethereal

[SOLVED] BUGREPORTiNG: Build: XeLL_Reloaded-testing-git01012012

Post by Ethereal » Sun Jan 15, 2012 1:02 am

Well, seems I found out why it was keeping to end up on Red Screen with Exception Vector.

The error was (and is) caused by the Kinect sensor connected to the Xbox 360

Once disconnected, Xell-testing boots with no issues.

Tried Mupen64 with no problem.

Ced2911's Pcsxr-xenon 0.5.1 for some reason does not start. Xell executes the .elf, I got black screen for a second and then Xell hangs. Last line of Xell is "Device tree prepared".

Hope this helps.
Last edited by Ethereal on Sun Jan 15, 2012 1:10 am, edited 1 time in total.

mojobojo

Re: [BUGREPORTING] XeLL

Post by mojobojo » Fri Jan 20, 2012 7:55 pm

XeLL-Rev: XeLL_Reloaded-testing-git17012012
Console Type: Retail
Console Revision: Jasper 512
Hack-Version: JTAG
Boot-Method: XeLL-Launch
Videocable: HMDI
Error-Description: No video output when set to mode 6 (VIDEO_MODE_VGA_1360x768) in kboot.conf when boot menu loads. When in boot menu unable to get controller (wireless) or keyboard input to switch through boot menu entries.

User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

Re: [BUGREPORTING] XeLL

Post by tuxuser » Sat Jan 21, 2012 4:23 pm

mojobojo wrote: Videocable: HMDI
Error-Description: No video output when set to mode 6 (VIDEO_MODE_VGA_1360x768) in kboot.conf when boot menu loads.
So you have the xbox connected via HDMI, you are changing the resolution via kboot.conf to VGA and get no video? wait, what.....
When in boot menu unable to get controller (wireless) or keyboard input to switch through boot menu entries.
Maybe try the attached build for controller input, should work then. If it still doesnt, try to resync your controller while in xell.

btw, allowed buttons via controller: DPAD-UP, DPAD-DOWN, A to confirm, B to cancel

Also, you can try navigate with usb keyboard as long as you want - its not implemented...

You can navigate via: IR Remote, Xbox360 Controller and UART (Serial Console).
Attachments
m0j0_210112.tar.gz
(591.83 KiB) Downloaded 358 times
I have no idea what I am doing but atleast I am trying

mojobojo

Re: [BUGREPORTING] XeLL

Post by mojobojo » Sat Jan 21, 2012 11:27 pm

[quote="tuxuser"]
[quote="mojobojo"]
Videocable: HMDI
Error-Description: No video output when set to mode 6 (VIDEO_MODE_VGA_1360x768) in kboot.conf when boot menu loads.
[/quote]

So you have the xbox connected via HDMI, you are changing the resolution via kboot.conf to VGA and get no video? wait, what.....
[/quote]

Haha woops, I didn't look that over very well. I was thinking about my native screen resolution instead of what cable I had connected. Dumb mistake on my part.

I was not sure after I started the boot menu if I may have needed the keyboard so I tried it as well. I did not see anything about the keyboard in the information, but I figured it would not hurt to try just in case it was in there.

Thanks for the build, I will test it in a moment.

Haze666

Re: [BUGREPORTING] XeLL

Post by Haze666 » Tue Feb 14, 2012 8:08 pm

XeLL-Rev: XeLL_Reloaded-testing-git25012012-RC2_fix1
Console Type: retail
Console Revision: Jasper 16mb
Hack-Version: Reset Glitch Hack
Boot-Method: Native
Videocable: HDMI
Error-Description: Xell loads fine, but whenever i try to load an elf file, or a linux distro i get a green tint over the screen, i have tried VGA and it resolves the issue, but i would prefer to use HDMI so i can have sound through the monitor. Also the HDMI cable works fine playing games and homebrew from dash.
Additional Information: I have tried multiple versions of Xell Reloaded, but since this was the most up to date version at the time of posting, i loaded it using XellLaunch then used the updxell.bin feature to update the native version of xell, because it wouldn't load linux  in spite of it being outdated, I didn't see anything else about my issue on Google this bug thread, also not sure if it might be my setup.
I'm using a gold plated monster hdmi cable "lifetime warranty ftw" hooking directly between my Xbox360 and my Asus 23.6in LED Monitor.

I'll be sure to update if i run into any more issues, I'm going to try out the other new features.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest