Xmenu 0.3

LibXenon Homebrew, XeLL etc.
User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

Xmenu 0.3

Post by tuxuser » Sun Jun 26, 2011 7:17 pm

Xmenu 0.3
=========

Xmenu is an elf loader with a basic gui.


Installation
============

Copy the file xenon.elf and the "xenon" folder to the root of your usb disk/pen.
Load it with the free60.org hack.


Changelog
=========

Version 0.3 :
- It's now possible to load custom icons. Put a ".png" image (32 bits, with alpha channel, 32*32 pixels would be better)
  alongside your executable file, with the ".ico" extension. Example :
  If you have an executable named "snes9x.elf", put the ".png" icon in the same directory with the name "snes9x.ico".

Version 0.2 :
- Graphics data is now loaded at startup, allowing to customise.
- Smaller fonts, this allow more items to be displayed.

Version 0.1 :
- Alpha testing version.


Thanks
======
Sasoseso from xboxhacker.net for sending me a free xbox 360, if all the people could be like you :)
Tmbinc of course for all his work.
Ced2911 for sega master system emulators sources, helped me a lot.
Ge0rG and ssmurf, because they are nice guys :)



Cpasjuste @ mydedibox.fr
Attachments
xmenu_src_20090914.tar.gz
(3.63 MiB) Downloaded 2807 times
I have no idea what I am doing but atleast I am trying

Doerek

Re: Xmenu 0.3

Post by Doerek » Tue Aug 30, 2011 12:34 pm

Code: Select all

cd into_the_directory
make CROSS_COMPILE=xenon- 
Last edited by Doerek on Tue Aug 30, 2011 11:28 pm, edited 1 time in total.

JPizzle
User
User
Posts: 4
Joined: Sat Mar 19, 2011 2:27 am

Re: Xmenu 0.3

Post by JPizzle » Tue Aug 30, 2011 3:15 pm

this works great, thank you  ;D

gomson

Re: Xmenu 0.3

Post by gomson » Tue Aug 30, 2011 5:09 pm

Thanks tux, much appreciated...

sjuut
User
User
Posts: 4
Joined: Fri Jul 22, 2011 3:45 pm

Re: Xmenu 0.3

Post by sjuut » Tue Aug 30, 2011 6:59 pm

I can't get this to work over HDMI, is it supported? I tried compiling with the new toolchain, I get errors, although I have met all requirements (zlib, libpng and SDL, lzx)..

antman1

Re: Xmenu 0.3

Post by antman1 » Mon Sep 26, 2011 2:42 pm

I tried just the distro from the compressed file and could not get it to load on my Glitched Falcon.  This would be great to use with everything though.  Great work to the creators.

psylent

Re: Xmenu 0.3

Post by psylent » Wed Oct 19, 2011 4:21 am

First off, sorry if this is a noob question... I search for an answer I promise.
So I used the xenon folder that was under the xmenu.tar\src\lwip\arch\ in conjuction with the xenon.elf file located under the distro folder and I cannot get this to load. Can someone provide a better explanation of what needs to happen here to make this work?

I think I found my answer in this thread "http://libxenon.org//viewtopic.php?t=0" . Is there a version of xmenu that is being distributed without be compiled?
Last edited by psylent on Wed Oct 19, 2011 4:31 am, edited 1 time in total.

Nighty

Re: Xmenu 0.3

Post by Nighty » Wed Oct 19, 2011 9:58 am

Xmenu don't work on my Jaspere 16MO  :-\
Can you help me ?
Image

antman1

Re: Xmenu 0.3

Post by antman1 » Wed Oct 19, 2011 5:25 pm

[quote="Nighty"]
Xmenu don't work on my Jaspere 16MO  :-\
Can you help me ?
[/quote]

I am in the same boat as you.  I think the menu would be great. 

Viral Doom

Re: Xmenu 0.3

Post by Viral Doom » Tue Oct 25, 2011 12:15 am

Same as me, does it support HDMI??

p4r0l3

Re: Xmenu 0.3

Post by p4r0l3 » Thu Oct 27, 2011 5:17 pm

Finally got this to compile after installing lantus' new libSDLXenon, it did take a couple minor edits. With updated libxenon, you need to change:

in src/main.c:

Code: Select all

xenos_init();
to
xenos_init(VIDEO_MODE_AUTO);
and in src/video.c

Code: Select all

do_edram_foo(xe, 1);
to
//do_edram_foo(xe, 1);
Not sure if the latter fix will break the edram init failure you guys are having further..but I see that the author has already commented out do_edram_foo in the drawBG function. Without that change, I get "undefined reference to `do_edram_foo'" when trying to compile.

c01eman.360
User
User
Posts: 9
Joined: Sat Nov 19, 2011 12:35 pm

Re: Xmenu 0.3

Post by c01eman.360 » Sat Nov 19, 2011 4:41 pm

can someone upload a precomplied version that will work with xell-reloaded. i cant get it to work or compile.

Doerek

Re: Xmenu 0.3

Post by Doerek » Sun Nov 20, 2011 11:48 am

@ c01eman.360
You've got mail...

Doerek

Re: Xmenu 0.3

Post by Doerek » Mon Nov 21, 2011 1:30 pm

@ Tuxuser
What is the difference between "zlx-browser" & "Xmenu0.3" ...what would you prefer?
I'm using zlx-browser...

User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

Xmenu 0.3

Post by tuxuser » Mon Nov 21, 2011 2:54 pm

I prefer you edit your posts instead of double posting.....

PS: ZLX
I have no idea what I am doing but atleast I am trying

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest