PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

LibXenon Homebrew, XeLL etc.
jayboy86

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by jayboy86 » Mon Mar 19, 2012 4:08 pm

cant be protection, i can get ff9 to work on my friends pc using an emulator. weird, if anyone has any ideas how to get it working let me know

i too will update it, but how do it edit it?

thx

jayboy86

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by jayboy86 » Mon Mar 19, 2012 5:38 pm

[quote="dreamboy"]
[quote="jayboy86"]
man i wish final fantasy 9 would work :(

i cant understand what the problem is, tried lots of versions and formats
[/quote]

i think its because of the video playback codec used on ff9, its diferent from the previous ff games. in the old version of pcsxr-xenon the game didnt get passed the squaresoft logo
[/quote]

I dont think your far off, i can get disc 2, 3 and 4 boot fine but i dont have any saved games so cant test any further. These working discs work because there is no opening video at the start, but disc 1 does have a opening video after the squaresoft logo.

is there anyway i can get a saved game for this on the usb stick and load it in the emu? what format would i need. thx for the help

barnhilltrckn

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by barnhilltrckn » Mon Mar 19, 2012 6:40 pm

I use psxmemtool for messing around with psx saves. You also have to rename the memcards that pcsxr-xenon uses from "card1.mcd" to "card1.mcr" in order for psxmemtool to transfer the save over right. Then after you do that name it back to "card1.mcd" to use on pcsxr-xenon.

The tool will read and right to mcd cards but for some reason it will not work onpcsxr-xenon unless you do it with the method I just described. If you would like me to inject the saves for you just upload the saves you want to use and I will make working cards for you. I have allready moved my FF7 saves over so I didnt have to start over either(albeit only on the 1st disc, my guys are around level 45 and only in the Nibel area :P).

jayboy86

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by jayboy86 » Mon Mar 19, 2012 8:29 pm

[quote="barnhilltrckn"]
I use psxmemtool for messing around with psx saves. You also have to rename the memcards that pcsxr-xenon uses from "card1.mcd" to "card1.mcr" in order for psxmemtool to transfer the save over right. Then after you do that name it back to "card1.mcd" to use on pcsxr-xenon.

The tool will read and right to mcd cards but for some reason it will not work onpcsxr-xenon unless you do it with the method I just described. If you would like me to inject the saves for you just upload the saves you want to use and I will make working cards for you. I have allready moved my FF7 saves over so I didnt have to start over either(albeit only on the 1st disc, my guys are around level 45 and only in the Nibel area :P).
[/quote]

got disc 4 to boot and used memcardrex to edit a EU save i got online, worked fine apart from some game and sound lag issues but i proves that the game does work (kind of) and that the video on disc 1 is the problem. maybe this could help on a fix and could explain why alot of other later psx games do not work.

anyone have any suggestions on changing settings that may help with the game/sound lag? would be great.

thx guys.

if anyone want the save file i have for disc 4 on ff9 let me know

barnhilltrckn

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by barnhilltrckn » Tue Mar 20, 2012 12:23 am

Well it seems that all the startup bugs have been worked out now so thats great news. Good work and thanks for all the work ced!!!

Now if we can only get fullspeed we may have a great emulator and then everyone will start to see how good libxenon really is. N64 and ps1 on the 360 with fullspeed is a pretty amazing thing imo. I just wish I could help out but sadly I am still trying to learn. I just try small and very, VERY basic edits of source code files. It isnt much but I am starting to understand the structure of it all.......atleast I think :P.

bloomorte

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by bloomorte » Tue Mar 20, 2012 1:29 am

Chrono Cross worked A LOT better in this new release, incredible!!

I got a red screen after I played for a while, though

User avatar
dreamboy
Global Moderator
Global Moderator
Posts: 48
Joined: Tue May 17, 2011 1:12 am
Location: Portugal

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by dreamboy » Tue Mar 20, 2012 2:20 am

[quote="bloomorte"]
Chrono Cross worked A LOT better in this new release, incredible!!

I got a red screen after I played for a while, though
[/quote]

I also noticed red screen when i pause the game in the middle of a battle on Final fantasy 7 ntsc, beside that everything works great. ill try other games soon
[align=center]ImageImage
xbox 360 Jasper JTAG 16mb - 2TB External 3.5HDD @ Dashboard 2.0.16202.0[/align]

bloomorte

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by bloomorte » Tue Mar 20, 2012 2:36 am

The red screen appeared when I used HW + Dynarec in the two first options at the options menu.
I changed to SW + Interpreter, and it ran very nice for almost an hour.

CG's have a few slows, nothing critical, i tried several different settings but couldn't make it run at full speed.
As soon as i can, i'll try Parasite Eve.

chunkz

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by chunkz » Tue Mar 20, 2012 3:38 am

@ced

I see that you are getting games to run that i am not according to the compatibility list.  Is there somthing i am missing like a trick to get some games running? Or maybe i just had a bad iso. Anyways i was just curious over the dramatizing difference on the couple games i saw as i couldnt get them to load at all and you had them running perfect according to list.



EDIT:
Nevermind i used the cdrcimg trick and some are now booting up but most still unable to play for me but no need to reply i dont think there is anything else i can do but make sure my iso's are proper.
Last edited by chunkz on Tue Mar 20, 2012 3:56 am, edited 1 time in total.

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by Ced2911 » Tue Mar 20, 2012 7:15 am

yes try to find some proper isos.

for ff9 it crash before the 1st video displayed,


https://picasaweb.google.com/1163750047 ... 5/Pcsxr062

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by Ced2911 » Tue Mar 20, 2012 12:24 pm

i'm removing modification for everyone in this list, cause some people always fuck the list, if someone want write right on it, pm me with your google doc account :)

Xplorer4x4

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by Xplorer4x4 » Tue Mar 20, 2012 9:00 pm

I just tried to compile using the latest libxenon from tux's git and the latest pcsxr source from github and got this error:

Code: Select all

/opt/free60-git/pcsxr-xenon/source/main/gui.cpp:26:26: fatal error: libntfs/ntfs.h: No such file or directory
compilation terminated.
make[1]: *** [gui.o] Error 1
make: *** [build] Error 2
I have a feeling this might not even be pcsxr related but i used tux's automated script(./build-xenon-toolchain libs) to compile all the libraries and have a feeling something did not compile right although the script confirmed everything installed properly, but I could be totally wrong to. :p

barnhilltrckn

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by barnhilltrckn » Tue Mar 20, 2012 9:32 pm

[quote="Xplorer4x4"]
I just tried to compile using the latest libxenon from tux's git and the latest pcsxr source from github and got this error:

Code: Select all

/opt/free60-git/pcsxr-xenon/source/main/gui.cpp:26:26: fatal error: libntfs/ntfs.h: No such file or directory
compilation terminated.
make[1]: *** [gui.o] Error 1
make: *** [build] Error 2
I have a feeling this might not even be pcsxr related but i used tux's automated script(./build-xenon-toolchain libs) to compile all the libraries and have a feeling something did not compile right although the script confirmed everything installed properly, but I could be totally wrong to. :p
[/quote]

Ok its a VERY simple fix. Go to ced's git and download both ntfs-xenon and ext2fs-xenon. Then extract both of those to there own folder, open up a terminal, become su, cd into the folder you extracted them too(you will have to do this two seperate times for each ntfs and ext2fs)and then type:

Code: Select all

make
make install
That should let you compile pcsxr-xenon now. Have fun!! 8)

ps: I thought ced had removed ntfs and ext2fs depencies from pcsxr-xenon. ???

Xplorer4x4

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by Xplorer4x4 » Tue Mar 20, 2012 9:38 pm

Thanks for tryin barnhilltrckn but that just brought a new problem. I tried to compile extfs-xenon from ceds githut but I got this error on make:
make[2]: *** [vfs.o] Error 1
make[1]: *** [xenon_release] Error 2
make[1]: Leaving directory `/opt/free60-git/ext2fs-xenon/source'
make: *** [xenon-release] Error 2

I just noticed when I compiled cube I get

Code: Select all

cp: cannot stat `free60/devkitxenon/examples/xenon/graphics/cube/cube.elf32': No such file or directory
yet it claims:

Code: Select all

cube.elf32 compiled, run it via xell
So i am going to go back and look in to libxenon.

EDIT:
Ok looks like the install script was using the old outdated sourforge git repo, swaped that out for tux's repo of libxenon since the free60/libxenon is broken atm.
Last edited by Xplorer4x4 on Tue Mar 20, 2012 10:49 pm, edited 1 time in total.

barnhilltrckn

Re: PCSXR-Xenon v0.62 by Ced2911 - Update 18/03/12

Post by barnhilltrckn » Wed Mar 21, 2012 12:47 am

[quote="Xplorer4x4"]
Thanks for tryin barnhilltrckn but that just brought a new problem. I tried to compile extfs-xenon from ceds githut but I got this error on make:
make[2]: *** [vfs.o] Error 1
make[1]: *** [xenon_release] Error 2
make[1]: Leaving directory `/opt/free60-git/ext2fs-xenon/source'
make: *** [xenon-release] Error 2

I just noticed when I compiled cube I get

Code: Select all

cp: cannot stat `free60/devkitxenon/examples/xenon/graphics/cube/cube.elf32': No such file or directory
yet it claims:

Code: Select all

cube.elf32 compiled, run it via xell
So i am going to go back and look in to libxenon.

EDIT:
Ok looks like the install script was using the old outdated sourforge git repo, swaped that out for tux's repo of libxenon since the free60/libxenon is broken atm.
[/quote]

Oh ok I see what is going on..........atleast I think so :P. It seems as you may have figured it out with your edit though. I always just download either ced's, tuxuser's, or gligli's libxenon and put that in whatever folder I put decide and build the toolchain from there. If that is what you have allready done then you should be ok but if not give that a try and you should be good to go.

If you need anymore help dont be afraid to ask though. I aint the only one here that is willing to help though so if I dont see it then I am sure someone else who knows will help. Good luck.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests