PCSXR-Xenon (PS1 Emulator) - compiling problems

Ask/talk about LibXenon Development/Compiling
User avatar
dreamboy
Global Moderator
Global Moderator
Posts: 48
Joined: Tue May 17, 2011 1:12 am
Location: Portugal

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by dreamboy » Tue Aug 21, 2012 7:29 am

i've manage to compile the project with SPU_PEOPS_PLUGIN by comenting //SPU_XENON_PLUGIN on sys.c , and changing the make file to PLUGINS_SPU :=  source/plugins/xenon_audio_repair110

but i still have no sound :\ am i missing someting? i've tested it with final fantasy 7
Last edited by dreamboy on Tue Aug 21, 2012 7:31 am, edited 1 time in total.
[align=center]ImageImage
xbox 360 Jasper JTAG 16mb - 2TB External 3.5HDD @ Dashboard 2.0.16202.0[/align]

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Tue Aug 21, 2012 8:38 am

don't know i don't have sound on my devbox ^^

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Wed Aug 22, 2012 3:54 pm

just made a new branch very experimental (threaded_gpu) that give a really nice boost :) need to test more game :)

ravendrow

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by ravendrow » Wed Aug 22, 2012 9:57 pm

is sk1080's libxenon testing required? n/m too excited lol i'll figure it out  ;D

sk1080

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by sk1080 » Wed Aug 22, 2012 10:06 pm

doesn't look like it

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Thu Aug 23, 2012 2:45 pm

didn't work like is expected, in tekken i got almost 70fps ( + 15 fps)

but in other i got some slowdown ...

User avatar
dreamboy
Global Moderator
Global Moderator
Posts: 48
Joined: Tue May 17, 2011 1:12 am
Location: Portugal

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by dreamboy » Tue Dec 04, 2012 4:27 pm

[quote="Ced2911"]
don't know i don't have sound on my devbox ^^
[/quote]

:) i finally manage to set the new spu plugin with sound working, ff9 plays nice with it hehe
[align=center]ImageImage
xbox 360 Jasper JTAG 16mb - 2TB External 3.5HDD @ Dashboard 2.0.16202.0[/align]

bebo_beta2002

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by bebo_beta2002 » Fri Apr 05, 2013 4:46 am

i hope u guys help me...i got this error at compiling

$ make -f Makefile.debug
[sys.c]
linking ... pcsxr-xenon.elf
main.o: In function `cmain()':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/main/main.cpp:213: und                                                                                                                efined reference to `usb2mass_ops_0'
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/main/main.cpp:213: und                                                                                                                efined reference to `usb2mass_ops_0'
zn.o: In function `ZN_SPUupdate()':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:46: undefined reference to `PEOPS_SPUasync(unsigned long)'
zn.o: In function `ZN_SPUreadRegister(unsigned long)':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:64: undefined reference to `PEOPS_SPUreadRegister(unsigned long)'
zn.o: In function `ZN_SPUreadDMA()':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:74: undefined reference to `PEOPS_SPUreadDMA()'
zn.o: In function `ZN_SPUwriteDMA(unsigned short)':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:84: undefined reference to `PEOPS_SPUwriteDMA(unsigned short)'
zn.o: In function `ZN_SPUwriteDMAMem(unsigned short*, int)':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:94: undefined reference to `PEOPS_SPUwriteDMAMem(unsigned short*,                                                                                                                int)'
zn.o: In function `ZN_SPUreadDMAMem(unsigned short*, int)':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:104: undefined reference to `PEOPS_SPUreadDMAMem(unsigned short*,                                                                                                                int)'
zn.o: In function `ZN_SPUopen()':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:140: undefined reference to `PEOPS_SPUinit()'
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:141: undefined reference to `PEOPS_SPUopen()'
zn.o: In function `ZN_SPUclose()':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:153: undefined reference to `PEOPS_SPUclose()'
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:154: undefined reference to `PEOPS_SPUshutdown()'
zn.o: In function `ZN_SPUregisterCallback(void (*)())':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:165: undefined reference to `PEOPS_SPUregisterCallback(void (*)()                                                                                                                )'
zn.o: In function `ZN_SPUfreeze(unsigned long, void*)':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/zn.cpp:175: undefined reference to `PEOPS_SPUfreeze(unsigned long, SPUFr                                                                                                                eeze_t*)'
xr_psemu.o: In function `SPUgetOne(unsigned long)':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/xr_psemu.cpp:43: undefined reference to `PEOPS_SPUreadDMA()'
xr_psemu.o: In function `SPUputOne(unsigned long, unsigned short)':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/plugins/xenon_audio_re                                                                                                                pair110/xr_psemu.cpp:53: undefined reference to `PEOPS_SPUwriteDMA(unsigned shor                                                                                                                t)'
cmount.o: In function `mount_interface':
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/newgui/cmount.c:48: un                                                                                                                defined reference to `usb2mass_ops_0'
/home/essam/free60project-github/pcsxr/pcsxr-xenon/source/newgui/cmount.c:48: un                                                                                                                defined reference to `usb2mass_ops_0'
/usr/local/xenon/usr/lib/libfat.a(disc.o): In function `get_io_usbstorage':
/home/Cc/xenon/fat-xenon/fat-xenon/libxenon/../source/disc.c:50: undefined refer                                                                                                                ence to `usb2mass_ops_0'
/home/Cc/xenon/fat-xenon/fat-xenon/libxenon/../source/disc.c:50: undefined refer                                                                                                                ence to `usb2mass_ops_0'
collect2: ld returned 1 exit status
/usr/local/xenon/rules:39: recipe for target `/home/essam/free60project-github/p                                                                                                                csxr/pcsxr-xenon/pcsxr-xenon.elf' failed
make[1]: *** [/home/essam/free60project-github/pcsxr/pcsxr-xenon/pcsxr-xenon.elf                                                                                                                ] Error 1
Makefile.debug:151: recipe for target `build_debug' failed
make: *** [build_debug] Error 2

i tried everything dreamboy stated in this topic as a solution but with no luck :(
i hope u guys help me

me-to-you93
User
User
Posts: 8
Joined: Mon Dec 30, 2013 10:38 am

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by me-to-you93 » Sun Mar 15, 2015 9:04 pm

Hi dreamboy.

I have the same problem, no sound in games.

How did you do to make it work ? Could you put the compiled archive here please ?
You would make a happy !!!

me-to-you93
User
User
Posts: 8
Joined: Mon Dec 30, 2013 10:38 am

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by me-to-you93 » Tue Mar 17, 2015 11:22 pm

dreamboy wrote:
Ced2911 wrote: don't know i don't have sound on my devbox ^^
:) i finally manage to set the new spu plugin with sound working, ff9 plays nice with it hehe
How did you do to have sound, I have no sound on all games I tested on my corona, but except that they run very well !
I don't know how to recompile xenon, but I would be so happy to make the sound work.

Any idea ?

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest