PCSXR-Xenon (PS1 Emulator) - compiling problems

Ask/talk about LibXenon Development/Compiling
Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Sun Aug 19, 2012 5:08 am

dev build :p imagine the time lost for selecting rom iso :p

User avatar
dreamboy
Global Moderator
Global Moderator
Posts: 48
Joined: Tue May 17, 2011 1:12 am
Location: Portugal

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by dreamboy » Sun Aug 19, 2012 7:19 pm

[quote="Ced2911"]
dev build :p imagine the time lost for selecting rom iso :p
[/quote]

lol yeah we can always make our own iso selecting code is not that hard, ced2911 how can i enable the old spu sound plugin? great work i've tested out final fantasy 9 and it works great  :D
Last edited by dreamboy on Sun Aug 19, 2012 8:52 pm, edited 1 time in total.
[align=center]ImageImage
xbox 360 Jasper JTAG 16mb - 2TB External 3.5HDD @ Dashboard 2.0.16202.0[/align]

ravendrow

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by ravendrow » Sun Aug 19, 2012 10:42 pm

[quote="dreamboy"]
[quote="Ced2911"]
dev build :p imagine the time lost for selecting rom iso :p
[/quote]

lol yeah we can always make our own iso selecting code is not that hard, ced2911 how can i enable the old spu sound plugin? great work i've tested out final fantasy 9 and it works great  :D
[/quote]

i could be wrong but try making a backup of the xenon_audio_repair folder then copy the contents of xenon_audio_repair110 to xenon_audio_repair after that is done open sys.c and change both instances of SPU_XENON_PLUGIN to SPU_PEOPS_PLUGIN... alternately you could just change the SPU lib folder in the makefile to xenon_audio_repair110 and make the needed changes to sys.c (this is just a guess please feel free to correct me if i am wrong)

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Mon Aug 20, 2012 6:35 am

[quote="ravendrow"]
[quote="dreamboy"]
[quote="Ced2911"]
dev build :p imagine the time lost for selecting rom iso :p
[/quote]

lol yeah we can always make our own iso selecting code is not that hard, ced2911 how can i enable the old spu sound plugin? great work i've tested out final fantasy 9 and it works great  :D
[/quote]

i could be wrong but try making a backup of the xenon_audio_repair folder then copy the contents of xenon_audio_repair110 to xenon_audio_repair after that is done open sys.c and change both instances of SPU_XENON_PLUGIN to SPU_PEOPS_PLUGIN... alternately you could just change the SPU lib folder in the makefile to xenon_audio_repair110 and make the needed changes to sys.c (this is just a guess please feel free to correct me if i am wrong)
[/quote]

the makefile is what i do

ravendrow

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by ravendrow » Mon Aug 20, 2012 6:47 am

so the only thing i can't find is what to name this stupid Suikoden.bin file to make it load, i found a bunch of image paths in main.cpp but it looks like it uses that when the GUI is enabled. the reason i want to use this particular game is because it kept crashing pcsxr-xenon 0.62 so i wanted to see if the improvements help.


@Ced2911 yeah i thought about it after i typed the first bit and decided to add the easier way lol :P

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Mon Aug 20, 2012 7:26 am

also keep in mind since compatibily is better, slow down are more commun ... i don't know if will be able to reach fullspeed now :s

dazz

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by dazz » Mon Aug 20, 2012 7:41 am

[quote="ravendrow"]
so the only thing i can't find is what to name this stupid Suikoden.bin file to make it load, i found a bunch of image paths in main.cpp but it looks like it uses that when the GUI is enabled. the reason i want to use this particular game is because it kept crashing pcsxr-xenon 0.62 so i wanted to see if the improvements help.


@Ced2911 yeah i thought about it after i typed the first bit and decided to add the easier way lol :P
[/quote]

Suikoden II seems to work near-on perfect for about 80-90% of the game, interesting that the first game doesn't.
The only issues I'm having is that saves stop working after a couple writes to the memory card, which can be solved by just restarting every time you save.

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Mon Aug 20, 2012 8:04 am

doesn't work ?

ravendrow

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by ravendrow » Mon Aug 20, 2012 8:40 am

well i cant find where to set the suikoden.bin file path for the dev version i compiled but as for 0.62 it starts to load then about 1 1/2 minute into the opening video it halfway drops out and there is this laser light show where the video has disappeared. if you leave it running it will drop a stackdump but i can't debug it cause i never compiled my own 0.62

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Mon Aug 20, 2012 8:55 am

in main.cpp
#define cdfile "path to iso"

you need to set the correct path here too
https://github.com/Ced2911/pcsxr-xenon/ ... n.cpp#L269

ravendrow

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by ravendrow » Mon Aug 20, 2012 9:18 am

[quote="Ced2911"]
you need to set the correct path here too
https://github.com/Ced2911/pcsxr-xenon/ ... n.cpp#L269
[/quote]

lol i think that right there is my problem didn't do that part assumed it was still set to the uda path , will let you know how it goes

User avatar
dreamboy
Global Moderator
Global Moderator
Posts: 48
Joined: Tue May 17, 2011 1:12 am
Location: Portugal

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by dreamboy » Mon Aug 20, 2012 10:35 am

[quote="ravendrow"]
[quote="Ced2911"]
you need to set the correct path here too
https://github.com/Ced2911/pcsxr-xenon/ ... n.cpp#L269
[/quote]

lol i think that right there is my problem didn't do that part assumed it was still set to the uda path , will let you know how it goes
[/quote]

yup try to set those paths, i did it before and it worked without problem, saving and loading on final fantasy 9, gameplay looked fullspeed for me. i'll try to setup the sound plugin on makefile later
Last edited by dreamboy on Mon Aug 20, 2012 10:45 am, edited 1 time in total.
[align=center]ImageImage
xbox 360 Jasper JTAG 16mb - 2TB External 3.5HDD @ Dashboard 2.0.16202.0[/align]

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Mon Aug 20, 2012 11:59 am

ff9 will not work with other plugin

ravendrow

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by ravendrow » Tue Aug 21, 2012 3:30 am

so just to make sure i am not making a stupid mistake here is what i have set

Code: Select all

#define cdfile "uda0:/Suikoden.bin"
@ like line 50 for the image path

Code: Select all

strcpy(Config.BiosDir, "uda0:/pcsxr/bios");
strcpy(Config.PatchesDir, "uda0:/pcsxr/patches_/");
for the bios

Code: Select all

strcpy(Config.Mcd1, "uda0:/pcsxr/memcards/card1.mcd");
strcpy(Config.Mcd2, "uda0:/pcsxr/memcards/card2.mcd");
for the memory card

and it still just resets to xell i also tried using uda instead of uda0 but eventually i just tried to use the gui to load the game

i manged to get the gui back up(just needed select changed to back in gui.cpp and re-enable in makefile) but there is a problem when i go to load a game it gives me a msg saying it cant read the drives. so is there an issue with the GUI mounting partitions?

Ced2911
Team
Team
Posts: 74
Joined: Tue Mar 15, 2011 2:20 pm

Re: PCSXR-Xenon (PS1 Emulator) - compiling problems

Post by Ced2911 » Tue Aug 21, 2012 6:43 am

https://github.com/Ced2911/pcsxr-xenon/ ... n.cpp#L218 :p fat was disabled only ntfs was enabled

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests