XeLL Beta Testers needed - Corona Video / eMMC support

This Forum is ment for posting News related to Homebrew on Xbox 360 or Xbox One (No XDK stuff)
User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

XeLL Beta Testers needed - Corona Video / eMMC support

Post by tuxuser » Sat Aug 10, 2013 5:44 am

Hey guys,

yeah, it has been pretty quiet here lately..
However, we are looking for Testers now to try out a new XeLL build with Corona video support and eMMC (reading-)support.

The following has to be tested:
* Video output on Corona with various videocables
* All web interface functions
* UpdXell on non-eMMC consoles
* Updflash on non-eMMC consoles
* Launching of ELF files


Just write me a PM if you are interested in participating. Thx :)

greetz
tux
I have no idea what I am doing but atleast I am trying

User avatar
XeXGolden
User
User
Posts: 10
Joined: Wed Aug 28, 2013 6:26 pm
Location: USA Eastern
Contact:

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by XeXGolden » Thu Aug 29, 2013 12:31 am

Wish I had a corona  >:( stupid falcon  :-\
New to this Site :)

Im making a asteroids game!!! :)
^ libxenon

Bizzy211

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by Bizzy211 » Sat Aug 31, 2013 11:25 am

Are beta testers still needed?

professor_jonny
User
User
Posts: 13
Joined: Tue Dec 27, 2011 11:09 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by professor_jonny » Sun Sep 01, 2013 8:21 am

I could not get updxell to work when booting from xell launch with the new xell-ggggg binary it would not find the update on the internal hdd (xtaf) or usb (fatx).

But I can confirm I can not get it to boot at all on my v2 mmc with the new binary (0.993) in flash only from xell launch with component hd and component ycbcr.

It boots and crashes with component hd and component ycbcr when cold booting.

on a trinity console it now fails to boot mplayer and crashes on the title screen with the new build but i guess it just need to be recompiled with the new video drivers and tool chain ?
Last edited by professor_jonny on Sun Sep 01, 2013 8:24 am, edited 1 time in total.

medaved
User
User
Posts: 8
Joined: Thu Aug 29, 2013 1:07 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by medaved » Sun Sep 01, 2013 12:40 pm

[quote="professor_jonny"]
on a trinity console it now fails to boot mplayer and crashes on the title screen with the new build but i guess it just need to be recompiled with the new video drivers and tool chain ?
[/quote]
on corona v2 too...

Swizzy
Team
Team
Posts: 43
Joined: Sun Sep 01, 2013 9:53 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by Swizzy » Thu Sep 05, 2013 7:43 pm

[quote="professor_jonny"]
I could not get updxell to work when booting from xell launch with the new xell-ggggg binary it would not find the update on the internal hdd (xtaf) or usb (fatx).

But I can confirm I can not get it to boot at all on my v2 mmc with the new binary (0.993) in flash only from xell launch with component hd and component ycbcr.

It boots and crashes with component hd and component ycbcr when cold booting.
[/quote]

It doesn't read fatx on external, it reads FAT16/FAT32 and EXT from external... XTAF might be bugged for internal HDD, i need to look into it... v2 corona's shouldn't ever try to update XeLL or the entire thing (it doesn't have MMC write support!)

Can you explain more what you mean with "boots and crashes"? do you get a red screen? if so... could you PLEASE post a picture or just simply the stackdump from it... this is very important as it helps find the cause of the error, i've had some reports of random crashes in the Xenos init (which shouldn't even be possible where the stackdump indicates mind you!)

professor_jonny
User
User
Posts: 13
Joined: Tue Dec 27, 2011 11:09 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by professor_jonny » Sat Sep 07, 2013 11:34 pm

Sorry I was meaning to say fat32 on usb, but you have explaned it xell does not have mmc write support it was just skipping the update.

But I can confirm I can not get it to boot at all on my v2 mmc with the new binary (0.993) with component hd and component ycbcr cables.

it just stops glitching no red screen with a stack dump just like it did with the old xell version.


But I can get it to load up xell using xell launch with the same cables with the binary dropped in the xell directory no problems.

i used jrunner to create my nand and the xell binary in *** is correct.

Swizzy
Team
Team
Posts: 43
Joined: Sun Sep 01, 2013 9:53 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by Swizzy » Sun Sep 08, 2013 8:05 am

[quote="professor_jonny"]
it just stops glitching no red screen with a stack dump just like it did with the old xell version.
[/quote]

Do you have UART connected? if so; what is the stack dump you get?

professor_jonny
User
User
Posts: 13
Joined: Tue Dec 27, 2011 11:09 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by professor_jonny » Sun Sep 08, 2013 10:41 am

ill see if i can find a nokia data cable and jack up a reader but at the moment nothing. im going to try some other cables as it works with every thing else.

the cables have an auto sencing electronic circuit and sence input and switch from the different console plugs and this may be a problem ?
but the console works correctly from retail.

Swizzy
Team
Team
Posts: 43
Joined: Sun Sep 01, 2013 9:53 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by Swizzy » Sun Sep 08, 2013 2:32 pm

[quote="professor_jonny"]
ill see if i can find a nokia data cable and jack up a reader but at the moment nothing. im going to try some other cables as it works with every thing else.

the cables have an auto sencing electronic circuit and sence input and switch from the different console plugs and this may be a problem ?
but the console works correctly from retail.
[/quote]

What happens if you grab the xell-2f.bin and put it next to XellLaunch from the 3.08 DL pack (don't rename it)? does that start? if so; you are most likely NOT using 0.993 even tho you think you do...

I don't know if it'll cause a problem, all i know is that my Squirt slaveboard(s) work perfectly fine, and so does a CK3i

professor_jonny
User
User
Posts: 13
Joined: Tue Dec 27, 2011 11:09 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by professor_jonny » Mon Sep 09, 2013 11:50 am

doing that it will boot from hdmi but not the component hd cables.

im starting to think the cables are at fault in some way?

Swizzy
Team
Team
Posts: 43
Joined: Sun Sep 01, 2013 9:53 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by Swizzy » Mon Sep 09, 2013 1:44 pm

[quote="professor_jonny"]
doing that it will boot from hdmi but not the component hd cables.

im starting to think the cables are at fault in some way?
[/quote]

It's possible yes, could you do me a favor and test it with component in the dash, and if it works there... start it up and grab the startup log using http://*ip*/LOG then post it somewhere like www.pastebin.com (it's going to be quite alot of text) the best is if you can start it using xellLaunch as that'll dump the ana from your console aswell (which the dashboard has set) preferebly you should set the dashboard to 720p before you do so tho as that's the default mode used...

peshkohacka
User
User
Posts: 6
Joined: Thu Jan 12, 2012 11:05 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by peshkohacka » Mon Sep 09, 2013 5:52 pm

Is XTAF support even tested with LibXenon? I saw there was a unix port of xtaf, but Xell still doesn't understand the Internal HDD is XTAF formatted. Also is DMA error with missing DVD driver a known bug?

siz
User
User
Posts: 33
Joined: Fri Jul 13, 2012 2:37 pm
Location: Denmark

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by siz » Mon Sep 09, 2013 9:24 pm

Xtaf is working for libxenon (there are some functions not implemented, write/mkdir etc., but read, opendir works). You can play videos on xmplayer from internal hdd.
#libxenon @ EFNet

Swizzy
Team
Team
Posts: 43
Joined: Sun Sep 01, 2013 9:53 pm

Re: XeLL Beta Testers needed - Corona Video / eMMC support

Post by Swizzy » Tue Sep 10, 2013 5:12 am

[quote="peshkohacka"]
Is XTAF support even tested with LibXenon? I saw there was a unix port of xtaf, but Xell still doesn't understand the Internal HDD is XTAF formatted. Also is DMA error with missing DVD driver a known bug?
[/quote]

DMA Error with missing DVD driver? what do you mean? if the drive is not connected you getting an error? that's like expected as it tries to communicate with hardware that isn't around... as long as it doesn't crash i don't consider it a bug...

About XTAF... it was tested before, i guess it's not been properly tested lately tho, and i think things have changed since last proper test... however, like siz said it works to read videos from it...

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests