FAQ/Troubleshooting - Reset Glitch Hack

Tutorials and Guides about the Reset Glitch Hack in general
User avatar
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany

FAQ/Troubleshooting - Reset Glitch Hack

Post by tuxuser » Mon Oct 31, 2011 5:02 pm

Some frequently asked Questions about the Reset Glitch Hack:

Programming the CPLD

Several "unknown Chips" are found by iMPACT:
Check your solder work, measure through for shorts/bridges. The LPT wire length could be the problem too, try to keep it as short as possible and use thicker wire for GND/3,3V.

iMPACT only finds an "unknown chip":
In this case you should use shorter wires on the LPT connector. You can directly solder the cables to the connector, no need to use a PCB.
A constant power supply is required (use thicker wires for GND and 3,3V).

iMPACT recognizes the chip (XC2C64A), but is showing an error while programming it:
This eventually can happen if you tried to program the CPLD too often before (unsuccessfully).
In this case, delete the auto save file of iMPACT, which gets created on every start of the application. Notice how the file is called and where it gets saved - Delete the file and the CPLD should get programmed fine.
The power supply could be causing this problem aswell. Try to use thicker wires for GND and 3,3V or switch to another power supply (maybe an external one which is providing the needed 3,3V).

Soldering the Hardware

I don't know how to wire my CPLD:
Look into this thread for a matching diagram: Thread

After soldering in the CPLD I get a ROD 0022:
This can happen if the wire from CPY_PLL_BYPASS is too thick or too thin. Try to use another cable.
Another possibly: You flashed the image with a wrong command via nandpro or you didn't flash the Hack-Image yet.

The point CPU_RST got damaged while soldering (Slim):
1. Get somebody, who knows what he does, to do this job
2. Near the CPU there's a point R4D4, use this as an alternative.


The point POST_OUT1 got damaged while soldering :
1. Get somebody, who knows what he does, to do this job
2. There's the following alternative point:



The point STBY_CLK, near the HANA, got damaged while soldering :
1. Get somebody, who knows what he does, to do this job
As an alternative point, you can use the left pad of the right Resistor, next to the original solder point. It's important that the cable goes through to the resistor - If the trace has no connection due to a ripped off solder point, the Xbox won't boot.

If R4B24 (Resistor) got damaged, you can replace it with a 33 Ohm/36 Ohm 1/4W Resistor.

For FATs there's another alternative (you have to scratch off the upper layer to get to the metal pad).

There's another Pad for STBY_CLK on FATs, it's named FT2R2 and is located on the backside of the motherboard. (The point where the white cable is connected to)



The console doesn't show any reaction after the soldering (doesn't turn on) :
The trace/solder point STBY_CLK could be damaged. Check it and solder again if needed. (It needs connection to the resistor!)

Using the Hack

Console doesn't show XeLL (only a black screen), no matter how long I wait:
You should make sure that you can actually hear the Resets (Power supply giving a high pitched sound, Fans slowing down around each 5 seconds)

-> Check if the .ecc Image was created correctly
---> Does the build.py script contain the valid 1BL Key ? (secret_1BL)
---> Did you choose the correct CD File? (CD/CDjasper)
---> If you have a bad block in the first 50blocks, did you remap them?
---> Did you flash the .ecc image with Nandpro 2.0e and the command "+w16" or "+w64" (depending on your NAND-Size) ?
Does your original dump have bad blocks in the first 0x50 Blocks? Then you have to remap them!
If you verified the above steps and it's still not working it could be cause of improper wire-positioning. You have to make sure that your cables (top and bottom) aren't too close to the "inductance coils" (see picture, labeled Ringkerndrosseln). They need at least a distance of ~3cm to them.... on both, top- and backside.
If both steps above don't help, there are two other methods to get it to glitch (faster or at all):
Make the wire to CPU_RST exactly 32cm long. (alternatively you can try 50cm aswell).
On Jasper boxes you can try to put a 68nF Capacitor across CPU_PLL_BYPASS and GND!
Exclusively on FATs you can do another mod to the CPLD wiring. The point on the CPLD which is faced by the black stripe of the diodes, Voltage Input, (not the GND points !) should be connected to the internal voltage regulator of the CPLD, which is outputting 1,8V. To do that, remove the 3x 1N4148 diodes, the 100nF cap and the 1K resistor and connect this pin directly to said 1,8V (Digilent CMOD Pin 5 to 1,8V of voltage regulator). Use a multimeter to find the right point!
For further information on this method: Thread

Jasper has CB 6751 or 6752 / X360 FAT has CB_A/CB_B in NAND:
If your Jasper has a CB of 6751 you have to provide a donor CB.6750.bin to the build.py script (don't ask for it here, you need to obtain it on your own!).
If you have the donor file build the image like this (notice the donor_CB.bin):
python common\imgbuild\build.py nanddumpname.bin common\cdxell\CD donor_CB.bin common\xell\xell-gggggg.bin
If the Jasper has a CB of 6752 it's not compatible with the Glitch Hack atm.
If your X360 FAT has a 2-part CB (CB_A and CB_B) it's not compatible with the Glitch hack atm.

Xell doesn't start, 3 green LEDs are lighting up
If XeLL doesn't boot but you are seeing 3 green LEDs on the Xbox's ROL you have to recheck the following solder point and eventually solder it again:

Replacement parts
R4D4 = 1,25 kOhm Resistor
R7R17 = 10 kOhm Resistor
R3B15 (Trinity) = 33 Ohm Resistor

Translated from german, from 360hacks.de

Credits to: Hoax, M tha MaN, Richter77, primo1337, Screamo, Nelix, SynTeX, Marcian, CosSCasH, Icekiller

To be continued...
Last edited by tuxuser on Sun Mar 18, 2012 7:05 pm, edited 1 time in total.
I have no idea what I am doing but atleast I am trying


Who is online

Users browsing this forum: No registered users and 1 guest