ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Tutorials and Guides about using/developing Linux/BSD/Mac OS @Xbox360
homeboycrusoe
User
User
Posts: 7
Joined: Fri Apr 11, 2014 8:47 pm

ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by homeboycrusoe » Fri Apr 11, 2014 8:56 pm

Hi Folks, I just want to know I am wasting my time trying to install Ubuntu 11.10 on my RGH Xbox360 (FALCON model)?

When I run install script ubuntu_oneiric.sh it gets past point off installing files on the HDD but then stops after getting 404 errors when trying to retrieve debootstrap below:

http://ftp.nl.debian.org/debian/pool/ma ... 38_all.deb

Sure enough, that file is no longer hosted there.

So should it be or is this thing dead in the water?

Any help much appreciated.

sema
User
User
Posts: 18
Joined: Fri Apr 29, 2011 8:08 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by sema » Fri Apr 18, 2014 9:18 pm

Hi. You have to edit the ubuntu_oneiric.sh file and change the URL for debootstrap to latest debootstrap_1.0.59_all.deb , but it's just your first step. This script also contains link to download video driver from this site which is unavailable (seems like nobody care anymore). Whatever, if you need it, I'll upload it for you, also with instructions. I run Ubuntu 11.10 on my Slim RGH, for morer then one year, and I'm hapy. ;)
Good luck.

homeboycrusoe
User
User
Posts: 7
Joined: Fri Apr 11, 2014 8:47 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by homeboycrusoe » Sun Apr 20, 2014 5:48 pm

@Sema, thanks for taking time to reply. 

If you can find the time to upload missing files and instructions to manually install them I would be a very happy chappy and greatly indebted to you.

Many Thanks

sema
User
User
Posts: 18
Joined: Fri Apr 29, 2011 8:08 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by sema » Mon Apr 21, 2014 9:20 pm

I have edited the install script to feat the latest requirements. This will install Ubuntu 11.10 on your HDD. I hope you know how to do this. If not, feel free to ask, I'll guide you through the proces.
Attachments

[The extension has been deactivated and can no longer be displayed.]


sema
User
User
Posts: 18
Joined: Fri Apr 29, 2011 8:08 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by sema » Mon Apr 21, 2014 9:57 pm

After succesful install, unzip and place the content of .zip in /lib/modules directory, you must have this: /lib/modules/3.5.4-xbox0.11.1 There are drivers for some devices. Also you have to replace (or edit) the file /etc/modules (atached).
Attachments

[The extension has been deactivated and can no longer be displayed.]

3.5.4-xbox0.11.1.zip
(9.7 MiB) Downloaded 334 times

User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by tuxuser » Mon Apr 21, 2014 9:59 pm

Isn't this the up-to-date version?
http://file.libxenon.org/free60/linux/xenosfb/ ?
I have no idea what I am doing but atleast I am trying

sema
User
User
Posts: 18
Joined: Fri Apr 29, 2011 8:08 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by sema » Mon Apr 21, 2014 10:01 pm

Boot with this kernel and kboot.conf Just place it on root of the usb stick
Attachments

[The extension has been deactivated and can no longer be displayed.]

[The extension has been deactivated and can no longer be displayed.]


sema
User
User
Posts: 18
Joined: Fri Apr 29, 2011 8:08 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by sema » Mon Apr 21, 2014 10:09 pm

[quote="tuxuser"]
Isn't this the up-to-date version?
http://file.libxenon.org/free60/linux/xenosfb/ ?
[/quote]
Tux, I'm realy glad to see you here. You help me a lot with having linux on my xbox, but suddenly this forum goes down, and I try to help people  who is interested in linux so am I. So, if you are here, let's work in direction of 3D video driver for xbox360 linux. I'm ready to work on it but I need some help. I have wrote to Felix Domke but no answer. Xbox 360 is realy amazing piece of hardware, let's make it better together.
Last edited by sema on Mon Apr 21, 2014 10:15 pm, edited 1 time in total.

sema
User
User
Posts: 18
Joined: Fri Apr 29, 2011 8:08 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by sema » Mon Apr 21, 2014 10:13 pm

By the way, the link in the script is right to the "up to day" you provided  ;)

User avatar
tuxuser
Administrator
Administrator
Posts: 301
Joined: Sat Feb 19, 2011 4:53 pm
Location: Germany
Contact:

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by tuxuser » Mon Apr 21, 2014 10:18 pm

[quote="sema"]
Tux, I'm realy glad to see you here. You help me a lot with having linux on my xbox, but suddenly this forum goes down, and I try to help people  who is interested in linux so am I. So, if you are here, let's work in direction of 3D video driver for xbox360 linux. I'm ready to work on it but I need some help. I have wrote to Felix Domke but no answer. Xbox 360 is realy amazing piece of hardware, let's make it better together.
[/quote]

I really appreciate your motivation.. but I won't participate in that section anymore.
Sorry to give you such negative response..
Last edited by tuxuser on Mon Apr 21, 2014 10:37 pm, edited 1 time in total.
I have no idea what I am doing but atleast I am trying

homeboycrusoe
User
User
Posts: 7
Joined: Fri Apr 11, 2014 8:47 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by homeboycrusoe » Tue Apr 22, 2014 7:29 pm

Nice one Sema.  I'll have a crack at the install tomorrow all being well.

I see a sound drivers folder...so the no sound issue has been resolved?

sema
User
User
Posts: 18
Joined: Fri Apr 29, 2011 8:08 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by sema » Tue Apr 22, 2014 8:44 pm

The sound issue I resolved using cheap chinesse external usb sound card, for that I have to build module. By the way, after you copy all this modules (and of course file /etc/modules) to the directory, you have to run from terminal sudo/sbin/depmod

homeboycrusoe
User
User
Posts: 7
Joined: Fri Apr 11, 2014 8:47 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by homeboycrusoe » Wed Apr 23, 2014 9:35 pm

Man, new probs. Script runs up to point of downloading debotstrap_1.0.59_all.deb and saving it, then seems to have a problem executing it. 

Errors:

line 22: mnt/ubuntu/work/data.tar.gz : no such file or directory exists.  Do I need tar app installed to unpack this file? 

Line 25 : debootstrap : command not found.

Error message for lines 27, 28, 33 and 39 - no such file or directory exists.

I'm running install script from a Live Cd Beta and using a standard 60Gb seagate 2.5" Sata HDD (not a M$ signed one - is this ok?).

Any help appreciated.

sema
User
User
Posts: 18
Joined: Fri Apr 29, 2011 8:08 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by sema » Thu Apr 24, 2014 3:33 pm

Don't know why inside the debotstrap_1.0.59_all.deb is data.tar.xz , so I have edited the install script. This one should work now. The HDD is ok, you can use any SATA 2.5 HDD since this script repartition and format it to ext.3. The Live CD Beta should be ok, but I prefer to use Ubuntu 10.10 Live from USB Stick, is much faster.
Attachments

[The extension has been deactivated and can no longer be displayed.]


homeboycrusoe
User
User
Posts: 7
Joined: Fri Apr 11, 2014 8:47 pm

Re: ubuntu_oneiric.sh Debooting Script for Ubuntu Gives 404 errors

Post by homeboycrusoe » Thu Apr 24, 2014 4:58 pm

Cheers.  I started off using 10.10 on an usb but the install script was wiping it so I reverted to Live CD beta.  Makes me wonder whether my drives are being recognised correctly.  I did a list and HDD is sda and usb was sdb so seem ok (no numbers after device).  You would think the script would only be interested in sda so not a good sign it was wiping usb flash drive.

That said, I note the script has the line : "# if /dev/sda is mounted then partitions get wiped by dd but sfdisk fails!".  Does this mean I should only attach HDD AFTER LiveCd boot to ensure NOT mounted or I am worrying about nothing?

Anyway, I'll use amended script and fingers crossed...     

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest